1. A breve aggiorneremo la piattaforma di Reboot per risolvere alcuni problemi con i plug-in, quindi chiediamo ancora un po' di pazienza, Lo staff di Reboot

[GUIDA + FAQ] Facciamo chiarezza sulle Masterkey e Firmware richiesti dai giochi

Discussione in 'News Switch' iniziata da AngelDavil88, 8 Dic 2018.

  1. AngelDavil88

    AngelDavil88 Livello 30

    Iscritto:
    31 Dic 2017
    Messaggi:
    2.211
    Like ricevuti:
    1.659
    Immagine.png

    Con il rilascio del firmware 6.2.0, Nintendo ha cercato in qualche modo di bloccare l'esecuzione dei cfw, o per meglio dire, l'avvio di copie di backup sulle nostre switch tant'è vero che ad oggi l'unico cfw compatibile con il firmware 6.2.0 è Atmosphere nella sua ultima versione 0.8.1. Come ben saprete, i possessori di SX OS, il cfw user-friendly più chiaccherato della scena, stanno ancora aspettando un imminente rilascio di una nuova versione che si renda compatibile con tale firmware. Le prossime uscite dei per essere avviati richiederanno le Masterkey 6 e un firmware 6.2.0. Ma vediamo nel dettaglio tutte le Masterkey disponibili sino ad oggi:

    MASTERKEY 0 (1.0.0-2.3.0)
    MASTERKEY 1 (3.0.0)
    MASTERKEY 2 (3.0.1-3.0.2)
    MASTERKEY 3 (4.0.0-4.1.0)
    MASTERKEY 4 (5.0.0-5.1.0)
    MASTERKEY 5 (6.0.0-6.1.0)

    MASTERKEY 6 (6.2.0)


    Per chi si trova su firmware 6.1.0 può avviare qualsiasi backup uscito sino ad oggi compresi quelli che richiedono il firmware 6.2.0, ma vediamo un po nel dettaglio alcune Domande e Risposte per capire un po come muoverci sulla scena Switch attuale:

    D: Ho appena comprato una console Nintendo Switch, posso installare un cfw e avviare copie di backup dei giochi?
    R: Tutte le Switch rilasciate prima di giugno 2018 sono modificabili con un cfw. Guarda questa lista e verifica se la console è patchata oppure no tramite il codice seriale riportato sulla scatola o sulla console

    D: Ho verificato il codice seriale e purtroppo la console è patchata, posso fare qualcosa?
    R: No, ad oggi non ci sono soluzioni. Cambiala, vendila o... aspetta e spera...!!! Tutto è possibile in futuro!

    D: Ho verificato il codice seriale e la console è moddabile, come proseguo?
    R: Se sei su un firmware minore al 6.1.0 aggiorna la console in modalità offline al 6.1.0 (se vuoi utilizzare SX OS) o al 6.2.0 (se vuoi utilizzare Atmosphere) seguendo questa guida e poi effettua un backup pulito della sysnand seguendo questa guida

    D: Sono su firmware 6.1.0 e utilizzo il cfw SX OS, mi consigli di aggiornare al 6.2.0?
    R: No, non ci sono attualmente ragioni per aggiornare in quanto tutti i giochi sono pienamente funzionanti e inoltre SX OS è l'unico cfw che permette di avviare XCI (cartucce virtuali prive di installazioni), avere l'emunand (una nand emulata a parte su micro SD) e avviare copie di backup da dispositivi usb quindi vai tranquillamente di SX OS

    D: Sono su firmware 6.2.0 e voglio a tutti i costi giocare a miei backup, che cosa posso fare?
    R: Installa l'ultima versione del cfw Atmosphere 0.8.1 seguendo questa mini guida

    D: Come posso verificare la Masterkey e il firmware richiesto da un gioco/update?
    R: Segui la mia guida sull'utilizzo di Switch Backup Manager per avere le info richieste

    STO UTILIZZANDO IL CFW ATMOSPHERE 0.8.1 SU FIRMWARE 6.2.0, POSSO AVVIARE TUTTI I GIOCHI?

    - Atmosphere attualmente permette di installare solo giochi in formato NSP (archivi contenenti file NCA) sulla nand o su micro SD tramite l'homebrew installer Tinfoil. Tutti i giochi che richiedono le MASTERKEY 6 (6.2.0) e firmware 6.2.0 sono pienamente supportati. Se vuoi convertire gli XCI in NSP segui questa guida (Il titolo della guida è sbagliato, permette di fare entrambe le conversioni)

    STO UTILIZZANDO IL CFW SX OS 2.3 SU FIRMWARE 6.1.0, POSSO AVVIARE TUTTI I GIOCHI?

    - SX OS permette di avviare TANQUILLAMENTE tutti gli XCI e tutti gli NSP che richiedono le MASTERKEY 4 (5.0.0-5.1.0) e firmware 6.1.0. Per tutti gli altri seguite questi esempi:

    - XCI con MASTERKEY 4 (5.0.0-5.1.0) e firmware richiesto 6.2.0 :arrowright: Va convertito in NSP con NSC Builder e installato con Tinfoil con l'opzione "ignora firmware"

    - XCI con MASTERKEY 5 (6.0.0-6.1.0) e firmware richiesto 6.1.0 :arrowright: Può essere avviato direttamente dal caricatore xci integrato in SX OS anche se l'icona del gioco apparirà bianca. In home apparirà l'icona di gioco regolare

    - XCI con MASTERKEY 5 (6.0.0-6.1.0) e firmware richiesto 6.2.0 :arrowright: Va convertito in NSP con NSC Builder e installato con Tinfoil con l'opzione "ignora firmware"

    - NSP con MASTERKEY 4 (5.0.0-5.1.0) e firmware richiesto 6.2.0 :arrowright: Va installato con Tinfoil con l'opzione "ignora firmware"

    - NSP con MASTERKEY 5 (6.0.0-6.1.0) e firmware richiesto 6.1.0 :arrowright: Va installato con Tinfoil ma non è necessaria l'opzione "ignora firmware"

    - NSP con MASTERKEY 5 (6.0.0-6.1.0) e firmware richiesto 6.2.0 :arrowright: Va installato con Tinfoil con l'opzione "ignora firmware"

    PS: Molti giochi, se avviati con una connessione wifi attiva, andranno in crash con il classico errore "Il software è stato chiuso a causa di un errore". Basta disabilitare la connessione wifi per risolvere il problema.

    PS2: Se qualcuno utilizza il cfw Atmosphere vi prego di fare delle prove sull'avvio dei giochi nsp piu recenti possibili che richiedano le MASTERKEY e FIRMWARE recenti, non vorrei aver detto cavolate! I miei test si basano su SX OS.
     
    #1
    Ultima modifica: 13 Dic 2018
    A klear, mikifantastik98, Rafel87 e 8 altri utenti piace questo elemento.
  2. IlVampirelloXY

    IlVampirelloXY Livello 18

    Iscritto:
    3 Feb 2016
    Messaggi:
    815
    Like ricevuti:
    401
    Ottimo lavoro
     
    #2
    A AngelDavil88 piace questo elemento.
  3. dante777

    dante777 Livello 6

    Iscritto:
    2 Nov 2018
    Messaggi:
    123
    Like ricevuti:
    9
    A me da errore con giochi anche vecchi tipo dead cells e il gioco di carte Uno avete idee?mi richiede all avvio di qualsiasi gioco l accesso a internet
     
    #3
  4. AngelDavil88

    AngelDavil88 Livello 30

    Iscritto:
    31 Dic 2017
    Messaggi:
    2.211
    Like ricevuti:
    1.659
    Qualcuno può testare l'avvio dei giochi che richiedono masterkey 5 e firmware 6.2.0 con Atmosphere e vedere se ci sono problemi vari?
     
    #4
  5. AngelDavil88

    AngelDavil88 Livello 30

    Iscritto:
    31 Dic 2017
    Messaggi:
    2.211
    Like ricevuti:
    1.659
    Se potessi ti aiuterei ma sono su sx os, per questo chiedo a qualcuno di testare i giochi per chi usa Atmosphere.
     
    #5
  6. student

    student Staff Livello 47 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    5.265
    Like ricevuti:
    5.431
    La masterkey per fw 6.2.0 è la 6, non la 5 :wink:
     
    #6
  7. AngelDavil88

    AngelDavil88 Livello 30

    Iscritto:
    31 Dic 2017
    Messaggi:
    2.211
    Like ricevuti:
    1.659
    Ho scritto da qualche parte che è la 5?
     
    #7
  8. laserion

    laserion Livello 3

    Iscritto:
    9 Dic 2018
    Messaggi:
    57
    Like ricevuti:
    15
    Ciao! Mi presento sono nuovo. E' da un pò che vi seguo, premetto che è da poco che ho acquistato una switch, ho verificato e risulta moddabbile. Ora il mio dubbio è questo vedendo le vostre guide ed altro, essendo ancora la console sul 4.01 e ancora pulita l' ho portata online aggiornandola al 6.20 soprattutto per non sbattermi troppo per il fatto della compatibilità exfat 32. La mia domanda da niubbo è questa, secondo voi ho compromesso qualcosa o adesso dopo aver fatto il backup della nand posso tranquillamente aggiornare con atmosphere?
    Grazie ancora per i vostri preziosi consigli passati e futuri!!
     
    #8
  9. student

    student Staff Livello 47 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    5.265
    Like ricevuti:
    5.431
    Off topic. Leggi il regolamento del forum. Leggi MEGLIO le guide, le risposte che cerchi sono già li.
     
    #9
  10. laserion

    laserion Livello 3

    Iscritto:
    9 Dic 2018
    Messaggi:
    57
    Like ricevuti:
    15
    Perdona, io sarò anche off topic, ma leggi meglio anche tu, sono niubbo, e educazione prima di tutto. Il carattere maiuscolo significa urlare e me non piacciono gli urlatori. Ora puoi anche bannare. Buon Natale a tutti voi!
     
    #10
  11. student

    student Staff Livello 47 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    5.265
    Like ricevuti:
    5.431
    Primo post in un forum dove palesemente MENTI perchè non hai probabilmente letto nemmeno mezza guida nè tanto meno il regolamento ed in più sei pure off topic; il passo successivo sarebbero state delle scuse ed invece ti tocca il meritato ban (per ora di 2gg). Buon Natale.
     
    #11
    A Khodeus piace questo elemento.
  12. w@lterm

    w@lterm Livello 3

    Iscritto:
    21 Dic 2020
    Messaggi:
    44
    Like ricevuti:
    3
    Ciao. Scarico un gioco (aggiornamento) che richiede Firmware 9.1.0 e master key 9.0 .. in formato .nsp
    la mia Switch è aggiornata a FW 11.0.1 .. Questo update dovrebbe funzionare ?
     
    #12
  13. Domyx-01

    Domyx-01 Advanced Advanced User Advanced

    Iscritto:
    4 Dic 2018
    Messaggi:
    1.542
    Like ricevuti:
    825
    Si
     
    #13
    A w@lterm piace questo elemento.
Sto caricando...

Condividi questa Pagina