1. A breve aggiorneremo la piattaforma di Reboot per risolvere alcuni problemi con i plug-in, quindi chiediamo ancora un po' di pazienza, Lo staff di Reboot

nodeMCU ESP8266 V3 mod 12-F

Discussione in 'ESP8266' iniziata da Fausto Fossi, 13 Apr 2021.

  1. Fausto Fossi

    Fausto Fossi Livello 1

    Iscritto:
    13 Apr 2021
    Messaggi:
    3
    Like ricevuti:
    0
    Salve a tutti ragazzi. Ho comprato da poco la scheda nodeMCU, con modulo ESP8266 V3 Mod 12-F della AZ-Delivery.
    Ho installato i drive per la scheda ESP prima di compilare un semplice sketch, ma durante la compilazione mi appare un errore.Nelle directory create durante il download eseguito dall'IDE arduino versione 1.8.0, mancano in effetti le librerie,ho cercato di caricarle manualmente ma senza alcun risultato.
    Qualcuno ha avuto problemi di questo tipo con questa scheda?
    grazie
     
    #1
  2. zoomx

    zoomx Livello 19

    Iscritto:
    12 Set 2015
    Messaggi:
    904
    Like ricevuti:
    347
    Non hai scritto quale sketch hai compilato ma il sospetto è che tu non abbia scelto nel menù la scheda nodeMCU e abbia compilato per Arduino UNO.
    L'IDE poi è da tempo alla versione 1.8.3
     
    #2
  3. Fausto Fossi

    Fausto Fossi Livello 1

    Iscritto:
    13 Apr 2021
    Messaggi:
    3
    Like ricevuti:
    0
    Ciao
    Grazie per aver risposto al messaggio , sarò piu preciso.
    Uso la versione IDE Arduino 1.8.5 su piattaforma Windows XP SP3.
    Come sketch ho selezionato la NodeMCU1.0 (ESP-12E Module) e come esempio ho caricato il file che qui allego"Blink.txt"; quando compilo mi compare il messaggio di errore descritto nell'allegato "errori.txt".
     

    File Allegati:

    • Errori.txt
      Dimensione del file:
      1,1 KB
      Visite:
      28
    • Blink.txt
      Dimensione del file:
      977 bytes
      Visite:
      14
    #3
  4. zoomx

    zoomx Livello 19

    Iscritto:
    12 Set 2015
    Messaggi:
    904
    Like ricevuti:
    347
    Diavolo, avevo scritto la risposta ma è andata persa. Non avrò premuto invia risposta.
    Riscrivo.
    Riscaricati lo zip dell'Ide, non l'EXE.
    Decomprimilo in una cartella, chiamiamola IDE ma puoi chiamarla come ti pare.
    Dentro IDE crei una cartella che chiami portable
    Lanci l'IDE e quindi nella sezione apposita metti il link che punta al file json che spiega all'IDE stesso cosa deve scaricare per installare il core ESP8266. Ma lo scaricamento va fatto dal board manager.
    Questa trafila crea una versione dell'IDE che sta tutta in una cartella, la puoi mettere anche su una pennetta USB e va.

    Potrebbe essere che la colpa sia di XP, non so se è ancora supportato ma di solito l'errore capita su link.exe.
     
    #4
  5. Fausto Fossi

    Fausto Fossi Livello 1

    Iscritto:
    13 Apr 2021
    Messaggi:
    3
    Like ricevuti:
    0
    Grazie del consiglio
    Ho eseguito come tu mi suggerivi , reinstallato e creata una cartella "PORTABLE" ma purtroppo temo che con questa scheda, Windows XP 32 non sia sufficiente xche mi da questo errore:
    (
    fork/exec C:\Programmi\Arduino\arduino-185\portable\packages\esp8266\tools\python3\3.7.2-post1/python3.exe: %1 non è un'applicazione di Win32 valida.
    Errore durante la compilazione per la scheda NodeMCU 1.0 (ESP-12E Module).

    )
    Forse dovrò fare le prove con WIN7 o altro???
     
    #5
  6. zoomx

    zoomx Livello 19

    Iscritto:
    12 Set 2015
    Messaggi:
    904
    Like ricevuti:
    347
    Su Win7 funziona sicuramente, ho una macchina con quella versione e fino adesso non ho avuto problemi.

    Visto che hai creato una portable puoi copiare la cartella su una pennetta e trasportarla in un'altra macchina o usarla dalla stessa pennetta.
     
    #6
Sto caricando...

Condividi questa Pagina