1. A breve aggiorneremo la piattaforma di Reboot per risolvere alcuni problemi con i plug-in, quindi chiediamo ancora un po' di pazienza, Lo staff di Reboot

Guida Offline kexploit Wii U 3.X.X - 5.5.1 (WebServer su PC)

Discussione in 'Guide WiiU' iniziata da StandardBus, 26 Ago 2016.

  1. nastys

    nastys Staff スタッフ Staff

    Iscritto:
    23 Gen 2015
    Messaggi:
    652
    Like ricevuti:
    210
    @RyujiAndy Il file .deb funziona meravigliosamente, grazie mille!
    Se vuoi ho anche creato un file .rpm (per RedHat/Fedora) utilizzando alien e modificandolo con il comando:
    Codice:
    sudo rpmrebuild -pe simple-server-kexploit-wiiu-1.1.1-2.noarch.rpm
    Ho dovuto rimuovere le righe con le directory già esistenti di sistema e aggiungere:
    Codice:
    Requires:      python
    Requires:      python-netifaces
    Requires:      python-pip
    Requires:  tkinter
    
    (non è il modo migliore... lo so :grimacing:)

    Forse sarebbe il caso di aggiungere queste versioni per Linux alla guida.
     

    File Allegati:

    #46
  2. RyujiAndy

    RyujiAndy Staff ᗧ͇̿ · · ᗣ͇̿ᗣ͇̿ᗣ͇̿ᗣ͇̿ Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    558
    Like ricevuti:
    390
    Io da vecchio userlinux preferisco ancora il terminale
    Codice:
    git clone https://github.com/RyujiAndy/Simple_Server_Kexploit_WiiU.git
    cd Simple_Server_Kexploit_WiiU/source
    ./server.py
    
     
    #47
    A Airboss piace questo elemento.
  3. nastys

    nastys Staff スタッフ Staff

    Iscritto:
    23 Gen 2015
    Messaggi:
    652
    Like ricevuti:
    210
    Io personalmente trovo scomodo aprire ogni volta il terminale, andare nella directory del programma ed eseguirlo. Preferisco aprirlo semplicemente dal menu:
    Screenshot_20160830_234100.png
     
    #48
  4. numerone

    numerone Livello 13

    Iscritto:
    6 Giu 2015
    Messaggi:
    483
    Like ricevuti:
    172
    Io da vecchio user GNU/Linux preferisco soluzioni semplici, efficaci e free software.
    Per esempio, si può benissimo prendere l'exploit ed hostarlo su apache web server che viene avviato come servizio, senza bisogno di passare per soluzioni non libere e quindi di dubbia fattezza.

    Per quanto riguarda il terminale o non terminale, interfaccia grafica, menù k, menù gnome, menù start, tutto è relativo e praticamente tutti i DE degni di nota hanno un comodo editor del menù che consente anche di inserire una voce che apre il terminale, si sposta in una directory ben precisa ed esegue alcuni comandi, non è quello il problema, secondo me.
     
    #49
  5. RyujiAndy

    RyujiAndy Staff ᗧ͇̿ · · ᗣ͇̿ᗣ͇̿ᗣ͇̿ᗣ͇̿ Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    558
    Like ricevuti:
    390
    Infatti l'idea nasce nel creare un programma che non necessita eccessive conoscenze e la prima versione l'ho scritta per raspberry, e non presentava nessuna interfaccia grafica, ma un semplice comando da dover lanciare, il tutti si é evolto quando ho voluto fare il portin su sistemi windows, ma ho voluto mantenere la semplicità
     
    #50
  6. Airboss

    Airboss Livello 2

    Iscritto:
    7 Lug 2016
    Messaggi:
    33
    Like ricevuti:
    1
    Buongiorno e grazie per la risposta.
    In effetti mi sono trovato il tuo post subito dopo aver inviato il mio.
    ho provato ad installare il .deb su Xubuntu 15.10 ma l'errore che mi restituisce è quello in allegato. Dopo aver provato la prima volta ho aggiornato cono stringa sudo apt-get install python-pip giusto per fugare ogni dubbio, ma l'errore persiste. Mi piace cimentarmi in queste cose e vorrei risolvere.
    Premetto che dovrebbe poi girare su Ubuntu 10.5 (è un eeepc datato ma ancora buono) altrimenti opterò per utilizzare uno smartphone vecchio da usare solamente al posto del eeepc.
     

    File Allegati:

    #51
  7. RyujiAndy

    RyujiAndy Staff ᗧ͇̿ · · ᗣ͇̿ᗣ͇̿ᗣ͇̿ᗣ͇̿ Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    558
    Like ricevuti:
    390
    Prova ad aggiornare pip con la seguente linear di comando:
    Codice:
    pip install --upgrade pip
    
    SE non funziona devi aggiornare la distro
     
    #52
  8. numerone

    numerone Livello 13

    Iscritto:
    6 Giu 2015
    Messaggi:
    483
    Like ricevuti:
    172
    Guarda che nel tuo caso i sorgenti ci sono e li ho pure letti, quindi non sentirti chiamato in causa :smile:
     
    #53
  9. nastys

    nastys Staff スタッフ Staff

    Iscritto:
    23 Gen 2015
    Messaggi:
    652
    Like ricevuti:
    210
    In Ubuntu (Unity), ad esempio, non è incluso nessun menu editor. Poi devi considerare che un pacchetto .deb, oltre a creare il collegamento con un solo click, installa automaticamente tutte le dipendenze richieste. È la miglior soluzione per chi non vuole perdere tempo o per chi non è un utente esperto. Pensa se Google Chrome non avesse un pacchetto .deb/.rpm...
     
    #54
  10. RyujiAndy

    RyujiAndy Staff ᗧ͇̿ · · ᗣ͇̿ᗣ͇̿ᗣ͇̿ᗣ͇̿ Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    558
    Like ricevuti:
    390
    Tutta questa discussione OT mi FA capire che a reboot Serve un repository
     
    #55
    A vValerio pPisano 2.0, nastys e Airboss piace questo elemento.
  11. Airboss

    Airboss Livello 2

    Iscritto:
    7 Lug 2016
    Messaggi:
    33
    Like ricevuti:
    1
    Purtroppo continua a restituire lo stesso errore (su 15.10) pur avendo aggiornato pip.
     

    File Allegati:

    • update.png
      update.png
      Dimensione del file:
      22,2 KB
      Visite:
      90
    #56
  12. RyujiAndy

    RyujiAndy Staff ᗧ͇̿ · · ᗣ͇̿ᗣ͇̿ᗣ͇̿ᗣ͇̿ Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    558
    Like ricevuti:
    390
  13. gianmarco

    gianmarco Livello 1

    Iscritto:
    20 Ago 2015
    Messaggi:
    14
    Like ricevuti:
    0
    Quindi in questo modo sara possibile avviare copie backup dei giochi?
     
    #58
  14. RyujiAndy

    RyujiAndy Staff ᗧ͇̿ · · ᗣ͇̿ᗣ͇̿ᗣ͇̿ᗣ͇̿ Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    558
    Like ricevuti:
    390
    Allora ho creato una repository per la wily (15.10)
    apri il terminale e digita:
    Codice:
    sudo add-apt-repository "deb http://deb.reboot.ms/wily wily main"
    
    ora importa la chiave
    Codice:
    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 36E61DCD
    
    accetta e aggiorna il database dei repository
    Codice:
    sudo apt-get update
    
    infine installa il programma
    Codice:
    sudo apt-get install simple-server-kexploit-wiiu
    
    P.S. al momento ho creato il repository per il wily ma prossimamente creero anche per le altre distro
     
    #59
    A StandardBus piace questo elemento.
  15. Airboss

    Airboss Livello 2

    Iscritto:
    7 Lug 2016
    Messaggi:
    33
    Like ricevuti:
    1

    Grazie mille... col file che mi hai postato ieri sera adesso il webserver va benissimo le dipendenze sono ok.
    Adesso provo ad aggiunger il repository.
    Thumbs up!
     
    #60
Sto caricando...

Condividi questa Pagina