1. A breve aggiorneremo la piattaforma di Reboot per risolvere alcuni problemi con i plug-in, quindi chiediamo ancora un po' di pazienza, Lo staff di Reboot

Primo emulatore per Nintendo Switch !

Discussione in 'News Switch' iniziata da student, 31 Dic 2017.

  1. student

    student Staff Livello 45 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    4.884
    Like ricevuti:
    5.051
    E'stato pubblicato su github il primo emulatore per Nintendo Switch ed è un emulatore del SNES basato sul snes9x !

    Molto scomodo da eseguire puo'essere avviato tramite Pegaswitch su firmwares uguali o inferiori a 3.0.0 ma non è di certo procedura semplice per l'utente medio.

    Per poterlo utilizzare è infatti attualmente necessario:
    - clonare il repository libtransistor;
    - compilare la sezione graphics-experimental-fs;
    - compilare ace_loader,
    - compilare libtransistor-snes9x2010;
    - dal repository libtransistor-retroarch, copiare libretro_switch.a di snes9x2010 per retroarch, creare una cartella chiamata fs, inserire la vostra ROM i tale cartella;
    - compilare retroarch;
    - avviare pegaswitch;
    - avviare ace_loader ed utilizzarlo per avviare retroarch

    Se cercate un metodo in 5 passaggi cercate su gbatemp :wink:
    Purtroppo il core prevede di integrare una ROM quindi essendo materiale coperto da copyright non puo'essere condiviso.

    Link al repository: https://github.com/reswitched/libtransistor-snes9x2010
     
    #1
    A feddy75, iostream, DanyH e 3 altri utenti piace questo elemento.
  2. Coolguy

    Coolguy Livello 15

    Iscritto:
    1 Feb 2015
    Messaggi:
    599
    Like ricevuti:
    100
    Student, a proposito di exploit, puyo puyo tetris versione jap per un possibile exploit funziona solo su fw 3.0? Ti risulta?
    Perche' mi pare di aver letto che su fw superiori non servirebbe!
     
    #2
  3. student

    student Staff Livello 45 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    4.884
    Like ricevuti:
    5.051
    Quello di puyo puyo non è un vero exploit (c'è un thread apposito dove mi apre di averlo spiegato), è solo un modo semplice per utilizzare il browser nascosto di switch con il quale poter andare su una pagina contenente un exploit. A quanto pare questo gioco in versione jap pare essere l'unico ad avere questo link che fa aprire il browser.
     
    #3
  4. Coolguy

    Coolguy Livello 15

    Iscritto:
    1 Feb 2015
    Messaggi:
    599
    Like ricevuti:
    100
    Si ma ti risulta che sia valido solo per il fw 3.0?
     
    #4
  5. student

    student Staff Livello 45 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    4.884
    Like ricevuti:
    5.051
    É un link presente all'interno di un gioco, non c'entra nulla con il fw.
     
    #5
  6. robertus

    robertus Livello 4

    Iscritto:
    2 Lug 2017
    Messaggi:
    77
    Like ricevuti:
    6
    pensate che sia meglio acquistare una switch, per avere un firmware piu' basso possibile, oppure non serve a nulla ?
     
    #6
  7. student

    student Staff Livello 45 Staff

    Iscritto:
    30 Ago 2015
    Messaggi:
    4.884
    Like ricevuti:
    5.051
    Aspetta che esca l'homebrew channel e poi decidi :wink:
     
    #7
  8. lionx

    lionx Livello 7

    Iscritto:
    28 Dic 2015
    Messaggi:
    173
    Like ricevuti:
    50
    =,( io ho aggiornato a 4.0.1 per Mario Odissey T.T
     
    #8
Sto caricando...

Condividi questa Pagina