1. A breve aggiorneremo la piattaforma di Reboot per risolvere alcuni problemi con i plug-in, quindi chiediamo ancora un po' di pazienza, Lo staff di Reboot

Qwertyoruiop: rilasciato kexploit PS4 4.55, POC anche su 5.05!

Discussione in 'News PS4' iniziata da StandardBus, 27 Feb 2018.

  1. StandardBus

    StandardBus Staff Alan Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    4.091
    Like ricevuti:
    5.307
    [​IMG]

    Gli utenti che hanno avuto la PS4 finora inchiodata su firmware da 4.55 a 5.01 oggi hanno finalmente qualcosa di concreto: Qwertyoruiop (Luca Todesco, ita) ha rilasciato il kexploit per firmware 4.55, raggiungibile alla pagina http://crack.bargains/hax455.txt , con la possibilità che la stessa falla sia presente anche sui firmware più recenti.

    Update: sembra che l'exploit per 5.01 funzioni anche su 5.05. Quindi dove nell'articolo si parla di FW 5.01 dovrebbe essere valido anche su 5.05

    Per scalare i permessi fino al kexploit però serve un entrypoint. Quest'ultimo è stato rilasciato poche ore fa da ALEXZZZ9, dopo la pubblicazione del kexploit 4.55 di Luca, e supporta tutti i firmware fino a 5.01.

    L'entrypoint, il cui codice è disponibile alla pagina github https://github.com/ALEXZZZ9/PS4-5.01-WebKit-Exploit-PoC permette a qualsiasi PS4 fino a firmware 5.01 di avviare codice non autorizzato in usermode.
    Dalla usermode grazie al kexploit di Luca sarà possibile ottenere i permessi di esecuzione sul kernel, rendendo possibile su 4.55 tutto ciò che finora è stato possibile su 4.05 tramite l'HEN: Backup, homebrew ed hack a livello di sistema.

    [​IMG]

    Curiosità: L'exploit di ALEXZZZ9 non è stato scritto da zero, ma è stato sviluppato sul lavoro del team ReSwitched per la creazione del PegaSwitch exploit (falla sempre trovata nel browser Webkit, ovviamente).
    Se non fosse per il browser web, che le case sono state praticamente obbligate ad inserire nelle ultime generazioni di console, probabilmente staremmo ancora facendo affidamento sui savegame exploit per trovare gli entrypoint, tradizione che come conferma l'exploit di Puyo Puyo Tetris su Switch 1.0.0 non è ancora stata abbandonata del tutto


    Tutti gli utenti che hanno una PS4 o una PS4 PRO su firmware compreso tra 4.55 e 5.01 possono testare la bontà dell'exploit puntando il browser della console all'indirizzo http://ps4.reboot.ms e cliccando sul pulsante 4.55 - 5.01 Proof Of Concept.

    [​IMG]

    Quale sarà il seguito di questa storia? Probabilmente il porting dell'HEN su 4.55.

    Stay Tuned.

    Piaciuto l'articolo?
     
    #1
    Ultima modifica: 27 Feb 2018
    A AtoM, PacPera, Ekros e 3 altri utenti piace questo elemento.
  2. rust

    rust Livello 1

    Iscritto:
    22 Ago 2015
    Messaggi:
    17
    Like ricevuti:
    4
    perfetto, avevo giusto aggiornato ieri dalla 5.01 alla 5.05! :fearscream:
    comunque bella notizia per la scena ps4
     
    #2
  3. Blkdrg

    Blkdrg Livello 5

    Iscritto:
    20 Feb 2017
    Messaggi:
    82
    Like ricevuti:
    9
    Testato e funzionante anche su 5.05
     
    #3
    A StandardBus piace questo elemento.
  4. Dogenberg

    Dogenberg Livello 4

    Iscritto:
    21 Gen 2016
    Messaggi:
    63
    Like ricevuti:
    5
    Su gbatemp qualcuno è riuscito a far funzionare l'exploit per 5.01 anche su 5.05 (o almeno così dicono)
     
    #4
  5. Dona97

    Dona97 Livello 13

    Iscritto:
    13 Gen 2016
    Messaggi:
    486
    Like ricevuti:
    39
    Io ho il firmware 4.73, sarà possibile fare come successo su firmware 4.05 o No??? Conviene aggiornare o No???
     
    #5
  6. Blkdrg

    Blkdrg Livello 5

    Iscritto:
    20 Feb 2017
    Messaggi:
    82
    Like ricevuti:
    9
    Si confermo, l'ho già testato questa mattina.. Alcuni utenti sono riusciti a far partire l'exploit sulla versione 5.50 beta, il che è probabile sony tappi la falla sulla versione definitiva del firmware
     
    #6
  7. StandardBus

    StandardBus Staff Alan Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    4.091
    Like ricevuti:
    5.307
    Si, a quanto pare l'exploit per 5.01 funziona anche su 5.05 senza modifiche, oppure hanno applicato qualche correzione al codice che gli permette l'esecuzione su 5.05.
    Fino a 4.55 hanno praticamente in mano l'HEN, devono solo aspettare ancora qualche giorno.
    Chi è su firmware superiore al 4.55 ha il webkit exploit, e non potrà avviare da subito l'HEN, ma ci sono buone speranze per il rilascio di un nuovo kexploit che funzioni fino a 5.XX, Qwertyoruiop l'ha già in privato da parecchio tempo.
     
    #7
    A PacPera piace questo elemento.
  8. Dona97

    Dona97 Livello 13

    Iscritto:
    13 Gen 2016
    Messaggi:
    486
    Like ricevuti:
    39
    Non capisco come mai Qwertyoruiop aveva deciso di non pubblicare niente e invece mo pubblica ahahah Ma meglio così ahahah
     
    #8
  9. goemon

    goemon Livello 4

    Iscritto:
    12 Ott 2015
    Messaggi:
    78
    Like ricevuti:
    16
    wow.. questo vuol dire che qualunque console in vendita va bene per l'exploit?
     
    #9
    A GIUSEPPE88 piace questo elemento.
  10. cirio

    cirio Livello 8

    Iscritto:
    25 Nov 2015
    Messaggi:
    214
    Like ricevuti:
    28
    Provato su 5.05 e funziona
     
    #10
    A StandardBus piace questo elemento.
  11. StandardBus

    StandardBus Staff Alan Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    4.091
    Like ricevuti:
    5.307
    Se rilascia è perchè ha qualche exploit migliore a disposizione e può permettersi di bruciare questo (che verrà patchato da Sony alla velocità della luce tramite il 5.50, probabilmente)

    Praticamente si. Come ho già detto sopra, fino a 4.55 avremo l'HEN presto, mentre per i 4.55+ ci sarà comunque da aspettare ma le premesse sono buone.
     
    #11
  12. Kaillo86

    Kaillo86 Livello 1

    Iscritto:
    20 Mag 2016
    Messaggi:
    19
    Like ricevuti:
    1
    Scusate una domanda....io possiedo la 4.05 con modifica Hen.…..ma non capisco perché installo i giochi ps2 e funziona tutto....ma i giochi ps4 installati mi trovo il lucchetto
     
    #12
  13. potboy

    potboy Livello 18

    Iscritto:
    7 Gen 2018
    Messaggi:
    876
    Like ricevuti:
    311
    bene il mio amato pes18 funziona solo da 5.0 che bella notizia significa che a parte l'online in offline si può giocare anche con questo titolo
     
    #13
  14. StandardBus

    StandardBus Staff Alan Staff

    Iscritto:
    15 Dic 2014
    Messaggi:
    4.091
    Like ricevuti:
    5.307
    Per avviare i giochi PS4 è necessario attivare l'HEN dopo ogni singola accensione. Qui siamo un po' OT comunque, se hai altri dubbi apri una nuova discussione nella giusta sezione del forum.
     
    #14
    A Kaillo86 piace questo elemento.
  15. Guglio

    Guglio ıllıllı

    Iscritto:
    3 Set 2016
    Messaggi:
    3.284
    Like ricevuti:
    2.276
    Bene mi sa che la fortuna è contro di me, proprio ieri ho aggiornato a 5.01 da 4.07 dov'ero visto che mi ero finalemente convinto. Ma credete sia finita qui? No ho aggiornato anche alla 5.50 beta 3, grazie MONDO :laughing:
     
    #15
Sto caricando...

Condividi questa Pagina