1. A breve aggiorneremo la piattaforma di Reboot per risolvere alcuni problemi con i plug-in, quindi chiediamo ancora un po' di pazienza, Lo staff di Reboot

SX OS 3.1.0 non fa avviare emuNAND 11.0.0

Discussione in 'Discussione generale Switch' iniziata da ElCianawy, 8 Gen 2021.

  1. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    Buongiorno a tutti,
    vi scrivo in quanto ho un problema con SX OS.
    Qualche giorno fa ho voluto aggiornare l'emuNAND alla 11.0.0 tramite ChoiDujourNX e ho inserito nella sd il file boot.dat aggiornato alla 3.1.0 di SX OS. Da questo momento non sono più riuscito ad avviare l'emuNAND in quanto nel momento in cui provo a lanciare il CFW inizia un loop tra il logo Nintendo e quello di SX OS. La console senza passare da SX OS si avvia senza problemi sull'OFW (che è ancora alla 9.1.0). Il problema è che stupidamente non mi ero fatto un backup della emuNAND prima dell'aggiornamento e adesso rischio di perdere quasi 2 anni di salvataggi se non dovessi riuscire a farla ripartire.
    La SD è da 128Gb ed era formattata in exFAT ma per scrupolo ho fatto un backup dei file all'interno e l'ho formattata in FAT32 senza però risolvere il problema che si presenta nello stesso e identico modo.
    Dopo il backup ho eliminato l’emunand presente nella sd e ne ho creata una nuova con versione firmware 9.1.0. Tutto funzionava perfettamente e ho provato ad aggiornare l’emuNAND come fatto precedentemente e anche in questo caso si presenta lo stesso problema. Appena provo a lanciare il CFW da SX OS con Emunand attiva inizia questo loop tra i due loghi.

    Riuscite a darmi una mano? mi scoccerebbe non poco perdere (da pollo) tutti i salvataggi.…
     
    #1
  2. gelderm

    gelderm Livello 13

    Iscritto:
    25 Apr 2017
    Messaggi:
    436
    Like ricevuti:
    146
    L'emuNAND sta in una partizione separata.
    Dovresti quindi ritrovarti due partizioni, una usata dalla emuNAND e l'altra con i file che normalmente stanno nella SD.
    Non so che formattazione tu abbia fatto, ma verifica se hai ancora le due partizioni.
    Quella della emuNAND solitamente è da 32 GB (29,8 GiB effettivi su SD)
    Quindi ti rimarrebbero 96 GB (89,4 GiB effettivi su SD)

    Avendo un backup potresti estrarre i salvataggi, in via estrema, tramite questa guida :arrowright: https://gbatemp.net/threads/edit-of...up-restoring-via-fusee-gelee-payloads.541081/
     
    #2
  3. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    Innanzi tutto grazie mille per la risposta.

    La mia emuNAND non è in una partizione separata in quanto in fase di creazione l'ho fatta come file per praticità.
    Nella mia sd al momento ho diverse cartelle nella root principale (Config, Nintendo, Emutendo, Switch, sxos) oltre ai file necessari per far partire sxos.
    All'interno della cartella "sxos" ho una cartella "emuNAND" che contiene i file .bin.
    Noto però che sotto "Emutendo" esiste una cartella che si chiama "save" con all'interno dei file che sinceramente non riesco a capire che estensione abbiano.
    La stessa cartella è anche presente sotto la cartella "Nintendo" con però all'interno meno file.
    Potrebbe bastare ricreare l'emuNAND basata sulla 9.1.0 e successivamente cambiare la cartella "save" presente sotto "Emunendo" con quella che ho salvato sul pc? tenendo conto che il backup che ho della sd è stato fatto successivamente all'aggiornamento alla 11.0.0.…
    La guida che mi hai linkato potrebbe essere una soluzione ma leggendola l'ho trovata abbastanza complicata e la terrei come ultima spiaggia...
     
    #3
  4. gelderm

    gelderm Livello 13

    Iscritto:
    25 Apr 2017
    Messaggi:
    436
    Like ricevuti:
    146
    Ah ok, meglio così!
    Non conosco come funzioni la modifica con SX OS e tanto meno la struttura delle cartelle dell'emuNAND. Io sono abituato a dover estrarre i salvataggi con app apposite e quindi non saprei dirti se quella cartella save in Emutendo possa contenere i save che ti servono. La trovo una cosa troppo semplice, ma chissà...
    Per il resto ti consiglio di attendere una risposta su come far rifunzionare il tutto e smanettare il meno possibile con la switch. Però se hai un po' di tempo puoi fare un'ulteriore copia della emuNAND e smanettare a PC con quella

    Estrarre i save da un backup :arrowright: https://gbatemp.net/threads/extract-save-from-nand-backup.514261/#post-8299285

    e uno con un problema simile al tuo :arrowright: https://gbatemp.net/threads/retriev...cidental-6-2-0-update-using-wi-fi-ota.524762/
     
    #4
  5. Chronoz74

    Chronoz74 Livello 1

    Iscritto:
    30 Dic 2020
    Messaggi:
    10
    Like ricevuti:
    1
    Ciao, qualche giorno fà ho avuto un problema simile al tuo, praticamente su ChoiDujourNX avevo selzionato la versione firmware 11.0.0 ed al riavvio del CFW mi dava schermo nero dopo il logo nintendo, poi ho riprovato scegliendo 11.0.0(exFat) ed ha funzionato senza problemi. Considera che ho lo switch aggiornato all'11.0.1.
     
    #5
  6. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    Purtroppo non è il mio caso perché ho scelto exFAT... in ogni caso hai potuto riprovare perché avevi un backup? io purtroppo non ne ho e quindi devo riuscire a recuperare i salvataggi dalla emuNAND non funzionante
    L'unica cosa che mi fa pensare è che ci sia qualche conflitto con il fatto di avere la sysNAND alla 9.1.0 perché nonostante sapessi che le due nand possono essere tranquillamente su versioni di firmware diverse ho letto anche sui link postati da gelderm delle frasi dove alludevano al fatto che il problema potesse essere dato dal disallineamento delle due nand...
    Vorrei provare ad aggiornare la sysNAND ma se poi non funzionasse mi ritroverei fregato in quanto non potrei più creare l'emuNAND perché si aggiornerebbe alla 11.0.1 (la sysNAND l'aggiornerei andando online dato che è pulita).
    Qualcuno ha informazioni più dettagliate su eventuali malfunzionamenti dati dal disallineamento delle due Nand?
     
    #6
  7. Alebed07

    Alebed07 Livello 1

    Iscritto:
    3 Gen 2016
    Messaggi:
    4
    Like ricevuti:
    0
    Ragazzi perdonate la domanda perché so che è borderline ma davvero non so più dove sbattere la testa, al punto che potrei certo farne a meno ma è diventata una questione di principio.

    Come si acquista una licenza sx os?

    Ho già cercato ovunque, scritto agli amministratori su Discord, cercato di registrarmi sul forum del team xecuter senza trovare alcuna risposta. C'è qualche anima pia in grado di aiutarmi? Grazie in anticipo
     
    #7
  8. Chronoz74

    Chronoz74 Livello 1

    Iscritto:
    30 Dic 2020
    Messaggi:
    10
    Like ricevuti:
    1
    Io ho potuto rifarlo perchè ho un vecchio backup della nand 6.2.0 ma da quello che ho avuto modo di capire leggendo qua e là mi sà che con ChoiDujourNX dovresti poter fare un downgrade della emuNAND. Quindi potresti provare a scaricare il firmware 10.0.2 e fare il downgrade.
     
    #8
  9. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    questo sarebbe una manna dal cielo... cercando in giro si trova qualcosa di fattibile con Choi su pc ma non trovo guide precise.
    Potrebbe esserci qualche rischio inserire una emuNAND alla quale è stato fatto un downgrade? a logica direi di no...
     
    #9
  10. Chronoz74

    Chronoz74 Livello 1

    Iscritto:
    30 Dic 2020
    Messaggi:
    10
    Like ricevuti:
    1
    Io mi sono documentato un pò e con ChoiDujourNX puoi fare quello che ti pare. Ti basta fare la stessa procedura che hai fatto per aggiornare la emuNAND, in poche parole puoi aggiornare o downgradare la emuNAND a tuoi piacimento. Ovviamente la emuNAND per avviarsi deve essere compatibile con l'ultima versione dell'SXOS.
    Come ti ho già detto, io ho la switch con OFW 11.0.1 e emuNAND 11.0.0 che avvio tramite SXOS 3.1.0 beta.
     
    #10
  11. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    Il problema è che la emuNAND dalla quale voglio recuperare i salvaggi non parte più.. devo trovare il modo di farle il downgrade da pc o in qualche altro modo

    Ho ricreato una emuNAND partendo dalla mia sysNAND 9.1.
    Successivamente, sempre tramite ChoiDuJourNX, ho provato ad aggiornare la nuova emuNAND al firmware 10.2 ma nel momento in cui provo a farla partire inizia lo stesso loop che ho anche con la 11.0.
    A questo punto mi viene da pensare che la emuNAND sia salva ma che SX OS non riesca ad avviarla per qualche motivo. Avete qualche idea?
     
    #11
  12. gelderm

    gelderm Livello 13

    Iscritto:
    25 Apr 2017
    Messaggi:
    436
    Like ricevuti:
    146
    #12
  13. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    #13
  14. gelderm

    gelderm Livello 13

    Iscritto:
    25 Apr 2017
    Messaggi:
    436
    Like ricevuti:
    146
    SX OS non si sa per quanto ancora verrà aggiornato. Non conosco come funzioni, ma se hai l'emuNAND dovresti poter avviare Atmosphere su quella
     
    #14
  15. ElCianawy

    ElCianawy Livello 1

    Iscritto:
    8 Gen 2021
    Messaggi:
    9
    Like ricevuti:
    1
    Sono riuscito a farla ripartire.
    Ho eliminato il contenuto presente sotto la cartella sxos\titles.
    Ho fatto un backup dei salvataggi e l'emuNAND ora funziona bene.
    Unica anomalia è che non riesco più ad accedere al menù di sx os: Inserendo jig e dongle tentando l'accensione con power + vol+ la console si accende mostrando il logo di sx os e successivamente parte direttamente l'emuNAND.
    La prima volta dopo aver eliminato la cartella sx os era partito correttamente permettendomi di lanciare il CFW su emuNAND
     
    #15
    A gelderm piace questo elemento.
Sto caricando...

Condividi questa Pagina